MEMBUAT DAN MERUBAH OBYEK

MEMBUAT DAN MERUBAH OBYEK

Table of Contents

MEMBUAT DAN MERUBAH OBYEK

MEMBUAT DAN MERUBAH OBYEK
MEMBUAT DAN MERUBAH OBYEK

Pemakai melihat obyek seperti Field,tombol , dan lainnya sebagai bagian dari disain halaman dari sebuah buku. sebagai contoh pemakai mengklik sebuah tombol untuk b erganti halaman, Hotword untuk melihat lebih informasi lebih lanjut, atau sebuah gambar untuk memulai suatu animasi. anda membuat dan merubah obyek-obyek untuk membangun sebuah buku dengan mendefinisikan bagaimana bentuk dan apa yang dilakukan oleh obyek tersebut.

Menggambar Obyek

ketika anda menggambar sebuah obyek,bentuk dan tipe awalnya ditentukan oleh perangkat yang anda pilih dari tool palette, dan ukuran serta proporsi akhirnya ditentukan dari seberapa jauh dan arah dari posisi awal anda, memulai pembuatan obyek. bila anda memilih sebuah obyek atau memakai sebuah perangkat, indikator pemilihan (selection indicator) akan menunjukan jenis dari obyek yang di pilih.
tool palette hanya ada pada level author.

Menggambar Obyek baru.

untuk membuat obyek Toolbook anda memilih sebuah perangkat dari tool palette, klik pada posisi dimana anda akan memulai obyek baru, lalu seret sampai mendapatkan ukuran yang anda inginkan. cara ini tidak berlaku bila anda ingin membuat polygon, angled line,ireguler polygon, dan curve.
Tidak seperti obyek yang dibuat dengan program gambar tradisional,obyek Toolbook mempunyai properti yang mengatur penampilannya.setelah menggambar obyek,anda dapat mengubah propertinya.

Menggambar dengan Openscript

Anda dapat memakai perintah draw untuk menggambar obyek dengan OpenScript. Anda juga harus menertakan sekurang-kurangnya dua titik lokasi, tergantung kepada jenis obyek akan digambar.Obyek segmen tunggal,seperti garis lurus,memerlukan dua titik. Untuk membuat kurva,busur atau potongan lingkaran,anda harus menertakan tiga titik,titik awal,titik tengah dan titik akhir.Sebuah polygon tidak beraturan atau rangkaian garis memerlukan sekurang – kurangnya tiga titik.Setiap titik dibuat dari dua buah bilangan dalam satuan page. bilangan pertama menunjukan jarak dari tepi halaman, dan bilangan kedua menunjukkan jarak dari tepi atas halaman. Untuk menggambar dengan Opensriptc gunakan Perintah berikut :

draw from to [to . . . >

sebagai contoh :

draw line from 1000, 1000 to 3000, 3000
draw arc from 1440, -1440 to 2880, -1440 to 2880,0
draw ellipse from 1000, 100 to 650, 874 to 0 , 0

Menggambar Poligon

Poligon beraturan , selanjutnya hanya disebut dengan poligon, adalah obyek dengan sisi-sisi sama panjang yang saling terhubung pada sudut yang sama.
Contoh, segitiga sama sisi adalah sejenis poligon yang terdiri dari tiga sisi , dan bujursangkar adalah poligon empat sisi. dalam toolbook anda selalu menggambar poligon dari titik tengahnya. waktu anda membuat poligon,jumlah sisinya tergantung pada bilangan yang anda pilih pada poligon palette. setelah anda menggambar poligon anda dapat merubah sudutnya tetapi tidak dengan jumlah sisinya.

untuk membuat sebuah Polygon (poligon) :

Memakai Interface

  • Munculkan Polygon Palette dengan memilih palettes dari menu View , lalu Polygon dari submenu.atau klik tombol polygon palette pada toolbar.
  • Pilih salah satu bentuk polygon atau ketikan pada kotak jumlah sisi yang diinginkan.
  • dengan menggunakan perangkat polygon yang terdapat pada tool palette arahkan pada tempat yang akan menjadi pusat dari polygonkemudian seret dari titik tengah tersebut sampai mencapai ukuran yang diingiinkan.

Memakai Openscript

untuk menampilkan polygon palette gunakan pernyataan show polygonPalette.Untuk menggambar sebuah polygon gunakan perintah draw dengan polygon sebagai jenis obyek diikuti dengan titik awal dan titik akhirnya.
sebagai contoh :
syspolygonshape = 8 == Jumlah sisi polygon = 8
draw polygon from 2000 , 2000 to 3000 , 3000

untuk menyembunyikan palette, jalankan pernyataan Hidepolygonpalette.

Menggambar Angled Line dan Irregular polygon

Angled Line adalah segmen garis yang saling terhubung satu sama lain. tempat terdapatnya sambungan garis tersebut dinamakan vertek (simpul). anda dapat membuat angled line ini dengan cara mengklik tempat- tempat yang menjadi posisi vertek tersebut.
cara membuat Irregular polygon sama dengan cara membuat angled line. bedanya , toolbook akan menutup ujung-ujungnya sehingga membentuk obyek tertutup.

untuk menggambar angled Line atau irregular polygon :

Memakai Interface

  • Pilih perangkat Angled Line atau Irregular Polygon dari tool palette.
  • Arahkan penunjuk Mouse pada tempat yang menjadi titik awal obyek lalu klik.
  • lanjutkan untuk mengarahkan dan mengklik untuk menambahkan titik-titik vertek sebanyak yang anda inginkan.tekan kunci CTRL bila anda ingin membatasi sudut menjadi garis 45 derajat.
  • untuk mengakhiri klik dua kali atau tekan kunci Esc.

bila anda memilih perangkat irregular polygon maka toolbook akan menghubungkan ujung – ujungnya dan mengisi area yang tertutup dengan bentuk sesuai yang terdapat pada pattern palette.

Memakai Openscript

— Menggambar angled line
draw angledLine from 500,500 to 1000,1000 to 1500,1500

–menggambar irregular polygon
draw irregular from 1000,1000 to 2000,500 to 2000,1500

Menggambar kurva

Anda menggambar kurva dengan klik sekali untuk kurva dan sekali untuk memulai mengatur kelengkungannya.Setelah selesai, anda dapat merubah bentuknya, juga dapat merubah bentuk dari ujung-ujungnya.

Untuk Menggambar kurva

Memakai Interace

  • Pilih perangkat curve dari tool palette.
  • Arahkan pada titik mulai kurva.
  • arahkan pada titik untuk mengatur kelengkungannya.
  • Lanjutkan untuk menentukan titik berikutnya guna menambahkan sebanyak kurva yang anda inginkan
  • Untuk mengakhiri , klik dua kali atau tekan kunci Esc.

Untuk merubah bentuk kurva, pilih perintah Reshape Curve dari menu Draw.

Memakai OpenScript :

draw curve from 500, 500 to 1000, 1000 to 1500 , 500

Merubah bentuk garis

Anda dapat menentukan gaya atau bentuk dari garis yang dipakai sebagai batasan obyek, seperti solid,putus-putus, atau titik-titik, dan juga ketebalannya serta bentuk ujung-ujungnya.

Memakai Interface

  • Pilih Obyek yang memiliki garis yang akan dirubahnya.
  • tampilkan line palette, lalu pilih salah satu bentuk dan ketebalan yang diinginkan.

Memakai Opensript

–menampilkan line pallete
show linepalette
–untuk merubah bentuk , isikan nilai linestyle dengan
— ketebalan (1,2,3,4,6 atau 8) atau dashed untuk garis
— putus-putus, atau dotted untuk garis titik-titik.
linestyle of selection = 4

selain itu anda juga dapat merubahbentuk dari ujung-ujung garis , misalnya menambahkan anak panah.Caranya :

Memakai Interface :

  • Pilih garis yang akan dirubah.
  • tampilkan line ends pallette (tekan kunci Ctrl)
  • pilih salah satu bentuk yang diinginkan.Sebelah kiri palette untuk titik awal garis dan sebelah kanan Palette untuk titik akhir garis.

Memakai Openscript :

–menampilkan line ends palette
show lineEndsPalette

— untuk merubah bentuk dari ujung-ujungnya , isikan
— nilai lineEndsStyle dengan dua buah parameter, ujung awal
–dan ujung akhir.
lineEndStyle of selection = openHead , filledTail

–untuk merubah ukurannya , isikan nilai lineEndSize dengan
— bilangan antara 1 sampai 9
lineEndSize = 6 , 6

Memilih Obyek

Sebelum anda merubah obyek atau mengatur propertinya, anda harus lebih dahulu memilih obyek tersebut.untuk memilih obyek yang baru selesai digambar,gunakan kunci spacebar.Untuk memilih obyek lainnya, gunakan perangkat pemilihan (selection tool) yang terdapat pada tool palette.Anda juga dapat menggunakan Opensript untuk memilih obyek dengan menyebutkan nama atau nomor ID-nya. Contoh :

selection = button “Next”
select button “button1”

untuk memilih beberapa obyek sekaligus, dapat digunakan beberapa cara :

Memakai Interface

  • Lakukan shift+Klik pada setiap obyek yang akan dimasukkan ke dalam pilihan.
  • Buat kotak disekeliling obyek-obyek yang akan dipilih dengan selection tool.
  • pilih select All dari menu Edit atau Klik selection tool dua kali untuk memilih seluruh obyek.

Memakai Openscript :

selection = button ” button” , field “field”
send selectAll
push “button ID 2 of page ID 3” onto selection

untu membatalkan pemilihan, ada beberapa cara :

Memakai Interface :

  • Klik di mana saja pada halaman, tidak di atas obyek
  • pada pilihan lebih dari satu, shift+klik pada obyek yang akan dikeluarkan dari pemilihan.

Memakai Openscript :

selection = null
clear selection
unselect selection

Mengatur properti obyek

Setiap obyek Toolbook mempunyai properti yang menetukan penampilan dari masing-masing obyek. Properti adalah suatu kategori informasi yang berhubungan tentang obyek, misalnya warna obyek. Nilai dari properti adalah infomasispesifik yang ditentukan sesuai kategorinya. Misalnya, nilai dari warna obyek adalah biru

Anda mengatur properti obyek dengan kotak dialog properties. Kotak dialog ini berbeda antar jenis obyek yang satu dengan jenis obyek lainnya. Tetapi semuanya memiliki lima buah properti dasar berokut ini (istilah OpenScript diletakkan dalam tanda kurung) :

  • Nama (name) : Menunjukkan nama dari obyek. Dalam Openscript, lebih mudah merujuk suatu obyek dengan namanya dari pada dengan nomor ID.
  • Lapisan ( Layer) : Menampilkan nomor lapisan tempat posisi obyek, menunjukkan urutan suatu obyek dibanding dengan obyek lainnya yang berada pada halaman atau background dari belakang sampai depan, dan mempengaruhi urutan penggambaran dan pengaksesan.
  • Nomor ( IDnumber) : Menunjukkan nomor identifikasi yang bersifat unik yang diberikan secara otomatis oleh ToolBook pada saat anda membuat obyek. Anda bisa menggunakan nomor ID ini untuk merujuk kepada suatu obyek dalam Openscript.
  • Memakai Warna-warna Windows ( useWindowsColors) : Mengatur sebuah obyek untuk menggunakan warna yang dispesifikasikan dalam windows Control Panel
  • Transparansi ( transparent) : Membuat obyek menjadi tembus pandang.

Untuk mengatur properti obyek :

Memakai Interface :

Buka kotak dilaog properti obyek, gunakan beberapa cara ini :

  • klik kanan dua kali pada obyek yang diinginkan
  • Klik kanan pada obyek. lalu klik tombol properti yang terdapat pada menu kanan.
  • Shift+klik dua kali pada obyek
  • Plih obyek dan pilih Properties dari menu Object.

Atur properti sesuai dengan keinginan, lalu tutup kotak dialognya

Memakai Openscript :

— memberi nama obyek
name of selection = “next”

— merubah layar
layer of button “next” = 3

Memindahkan Obyek

Anda dapat memilih lalu menyeret suatu obyek untuk dipindahkan ke posisi lain. Anda juga dapat merubah bentuknya dengan membalik atau memutarnya.

Untuk memindahkan obyek pada halaman :

Memakai interface :

  • Pilih selection tool dari palette
  • Arahkan penunjuk pada bagian dalam obyek, lalu tekan dan seret obyek ke posisi barunya. Untuk membatasi gerakan secara horisontal atau vertikal saja, tekan kunci Ctrl pada saat menyeretnya

Memakai Openscript :

— memindahkan obyek langsung ke posisi tertentu
move button ” next” to 0, 0

— memindahkan obyek relatif dari posisi mula-mulanya
move button “next” by 1000, 1000

Membalik dan memutar obyek

Anda dapat merubah bentuk obyek dengan membalik atau memutarnya. Membalik obyek berarti memindahkan obyek berdasarkan titik tengahnya. anda dapat menggabungkan keduanya untuk mengubah bentuk suatu obyek.

Untuk membalik atau memutar obyek :

  • Pilih obyek yang akan dibalik atau diputar
  • Plih salah satu sub menu dari menu draw

 

  1. Flip horizontal : Membalik obyek yang dipilih secara horisontal
  2. Flip vertical : Membalik obyek yang dipilih secara vertikal
  3. Rotate left : Memutar yang dipilih 90 derajat berlawanan arah jarum jam.
  4. Rotate Right : Memutar obyek yang dipilih 90 derajat searah jarum jam

Merubah ukuran dan bentuk Obyek

Untuk merubah dari obyek :

Memakai Interface :

  • Pilih Obyeknya, lalu pilih Reshape dari menu Draw. Selection Handle berubah menjadi reshape handle
  • Seret salah satu reshape handle sampai ke bentuk yang diinginkan.
  • klik di luar obyek untuk selesai.

Untuk menyisipkan vertek, tekan kunci shift dan seret sebuah reshape handle ke tempat penyisipan. Untuk menghapus vertek,tekan kunci Shift+CTRL sambil mengklik salah satu reshape handle.

Memakai Openscript :

— Merubah bentuk sebuah angled line menjadi bentuk zig – zag
vertices of angled “zigzag”
” 1000, 1000 , 2500 , 2000 , 4000 , 1000 , 5500 , 2000 ”

Mengelompokkan Obyek

Anda dapat memakai Toolbook untuk membuat suatu obyek yang lebih rumit yang tersusun atas obyek-obyek bebas.Kumpulan obyek-obyek ini disebut group. Group ini memiliki sendiri propertinya. Anda tetap bebas merubah propeti obyek yang lain atau properti group.

Untuk membuat atau membatalkan group :

Memakai Interface :

shift+klik masing – masing obyek yang akan dikelompokkan. Tekan kunci CTRL+G. untuk membatalkan group (ungroup), pilih group yang akan dibatalkan lalu tekan kunci Ctrl+G.

Memakai Openscript :

— memilih obyek dan mengelompokkannya (grouping)
selectbutton “next” , button “previous”
send group
name of selection = “navigation button”

— membatalkan pengelompokan (ungrouping)
select group “navigation button”
send ungroup

Memindahkan obyek antar layer

Layer (lapisan) adalah suatu tempat dimana Toolbook meletakkan setiap obyek dalam urutan relatif dari obyek-obyek yang terdapat pada background atau halaman. layer tidak dapat dilihat, tetapi obyek yang menempati layer tersebut dapat dilihat.
pada saat anda merubah layer suatu obyek,Toolbook akan merubah layer dari obyek-obyek yang lain.Contoh, bila merubah layer 4 menjadi 2, maka layer 2 akan menjadi 3 dan layer 3 menjadi 4. layer 1 akan tetap. Nomor layer yang lebih kecil berarti lebih dekat ke dengan dasar background atau halaman.

Untuk memindahkan layer suatu obyek ke layar tertentu :

memakai Interface :

Buka kotak dialog properti dari obyek yang bersangkutan.
Isikan sebuah bilangan untuk menjadi layer yang diinginkan, lalu tutup kotak dialog.

Memakai openscript :

— memindahkan ke layer 4
layer of button “stop” = 4

— memajukan 2 layer ke depan
increment layer of button “stop” by 2

Sumber :